2015-10-18 4 views
1

我在Dartson看到一個奇怪的問題& mongo_dart。Pubspec.yaml拋出不一致的錯誤並且沒有衝突

我正在運行mongo_dart 0.1.46。 - 我需要升級它mongo_dart 0.2.4

然而,當我升級mongo_dart - 我碰到下面的錯誤有關dartson

包mongo_dart具有匹配源自0.2.4沒有版本: - 門票取決於版本0.2.4

使用:

dependencies: 
#Server Dependencies 
    json_object: "1.0.19" 
    mongo_dart: "0.2.4" 
    connection_pool: "0.1.0+2" 
    dartson: "0.2.4" 
    guinness: "0.1.17" 
    html: "0.12.2" 
    shelf: '>=0.6.2 <0.7.0' 
    shelf_static: "0.2.2" 
    shelf_route: "0.14.0" 

這很奇怪,因爲mongo_dart: '0.2.4' 存在Ø ñpub.dartlang,它工作在隔離 https://pub.dartlang.org/packages/mongo_dart


通過測試去除每個單個包裝pubspec.yaml的,我是能夠識別與dartson衝突。

如果我移動到dartson依賴列表的頂部,我得到相反的:

dependencies: 
#Server Dependencies 
    dartson: "0.2.4" 
    json_object: "1.0.19" 
    mongo_dart: "0.2.4" 
    connection_pool: "0.1.0+2" 
    guinness: "0.1.17" 
    html: "0.12.2" 
    shelf: '>=0.6.2 <0.7.0' 
    shelf_static: "0.2.2" 
    shelf_route: "0.14.0" 

包dartson具有符合0.2.4源自沒有版本: - 門票依賴於0.2版本。 4

一起刪除dartson允許mongo_dart正確安裝。

這兩個庫之間存在已知問題嗎?有沒有浮出水面的衝突?

問題:我如何獲得mongo_dart 0.2.4與0.2.4 Dartson

回答

1

我經營的酒吧得到詳細模式您pubspec運行,這些問題似乎是從包不同的依賴性logging Dartson取決於對目前的0.11版本,您可以問dartson作者在0.9版本依賴性,mongo_dart,他們有一些思考的logging

當前版本的同時,您可以嘗試dependency_ovverride添加到您的pubspec。當我添加ovverride到您的pubspec,它適用於我

name: test_pubspec 

dependencies: 
    json_object: "1.0.19" 
    mongo_dart: "0.2.4" 
    connection_pool: "0.1.0+2" 
    dartson: "0.2.4" 
    guinness: "0.1.17" 
    html: "0.12.2" 
    shelf: '>=0.6.2 <0.7.0' 
    shelf_static: "0.2.2" 
    shelf_route: "0.14.0" 
dependency_overrides: 
    logging: '^0.11.0' 
相關問題