2017-11-10 14 views
1

我正在嘗試將我的網站部署到aws ec2。它在python/django中,我想學習如何自己部署網站。我對aws的EBS有一些問題,所以首先我想知道如何手動執行此操作。 我決定爲此使用gunicorn和nginx。Django需要Nginx幫助

我可以使用gunicorn在虛擬ENV運行的網站,我在/home/ec2-user/gunicorn_start.bash創建下面的腳本:

#!/bin/bash 

NAME="davidbiencom"         # Name of the 
application 
DJANGODIR=/home/ec2-user/davidbien    # Django project directory 
SOCKFILE=/home/ec2-user/virtual/run/gunicorn.sock 
USER=ec2-user          
GROUP=ec2-user          
NUM_WORKERS=3          
DJANGO_SETTINGS_MODULE=davidbiencom.settings    
DJANGO_WSGI_MODULE=davidbiencom.wsgi      

echo "Starting $NAME as `whoami`" 

# Activate the virtual environment 
cd $DJANGODIR 
source /home/ec2-user/virtual/bin/activate 
export DJANGO_SETTINGS_MODULE=$DJANGO_SETTINGS_MODULE 
export PYTHONPATH=$DJANGODIR:$PYTHONPATH 
# Create the run directory if it doesn't exist 
RUNDIR=$(dirname $SOCKFILE) 
test -d $RUNDIR || mkdir -p $RUNDIR 

# Start your Django Unicorn 
# Programs meant to be run under supervisor should not daemonize themselves (do$ 
exec gunicorn ${DJANGO_WSGI_MODULE}:application \ 
--name $NAME \ 
--workers $NUM_WORKERS \ 
--user=$USER --group=$GROUP \ 
--bind=unix:$SOCKFILE \ 
--log-level=debug \ 
--log-file=- 

因爲沒有錯誤此運行良好,我相信。 接下來我安裝nginx並啓動服務。我確認它正在運行,因爲我收到歡迎頁面。接下來,我做到以下幾點:

  1. 轉到/etc/nginx/nginx.conf並添加以下到http

    包括/etc/nginx/sites-enabled/*.conf;

然後我在/ etc/nginx/sites-available和sites-enabled中創建了兩個文件夾。 我創建一個文件davidbien.conf並輸入以下內(修訂版):

upstream app_server { 
# fail_timeout=0 means we always retry an upstream even if it failed 
# to return a good HTTP response 

# for UNIX domain socket setups 
server unix:/home/ec2-user/virtual/run/gunicorn.sock fail_timeout=0; 

# for a TCP configuration 
# server 192.168.0.7:8000 fail_timeout=0; 
} 

server { 
listen 80; 
server_name 35.176.185.50; 

#Max upload size 
client_max_body_size 75M; # adjust to taste 

location /static/ { 
    root /home/ec2-user/davidbien/static; 
} 

location/{ 
    # checks for static file, if not found proxy to app 
    try_files $uri @proxy_to_app; 
} 

location @proxy_to_app { 
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; 
    # enable this if and only if you use HTTPS 
    # proxy_set_header X-Forwarded-Proto https; 
    proxy_set_header Host $http_host; 
    # we don't want nginx trying to do something clever with 
    # redirects, we set the Host: header above already. 
    proxy_redirect off; 
    proxy_pass http://app_server; 
    } 
} 

我保存這個文件並運行以下命令:

ln -s /etc/nginx/sites-available/davidbiencom.conf /etc/nginx/sites-enabled/davidbiencom.conf 

此步驟完成後我重啓nginx的,我當我輸入IP地址時,我得到502錯誤的網關錯誤。

這裏有什麼問題? 謝謝。

編輯: 這裏的錯誤日誌的無功/日誌/ nginx的/ error.log中

2017/11/10 22:26:27 [error] 27620#0: *1 open() "/usr/share/nginx/html/favicon.iicon.ico" failed (2: No such file or directory), client: 2.96.149.96, server: $localhost, request: "GET /favicon.ico HTTP/1.1", host: "35.176.185.50",referrer: "http://35.176.185.50/" 

編輯2: 這裏的等/ nginxnginx/conf目錄文件:

http { 
log_format main '$remote_addr - $remote_user [$time_local] "$request" ' 
        '$status $body_bytes_sent "$http_referer" ' 
        '"$http_user_agent" "$http_x_forwarded_for"'; 

access_log /var/log/nginx/access.log main; 

sendfile   on; 
tcp_nopush   on; 
tcp_nodelay   on; 
keepalive_timeout 65; 
types_hash_max_size 2048; 

#include    /etc/nginx/mime.types; 
#default_type  application/octet-stream; 

# Load modular configuration files from the /etc/nginx/conf.d directory. 
# See http://nginx.org/en/docs/ngx_core_module.html#include 
# for more information. 
include /etc/nginx/sites-enabled/*.conf; 

index index.html index.htm; 

server { 
    listen  80 default_server; 
    listen  [::]:80 default_server; 
    server_name localhost; 
    root   /usr/share/nginx/html; 

    # Load configuration files for the default server block. 
    include /etc/nginx/default.d/*.conf; 

    location/{ 

# redirect server error pages to the static page /40x.html 
    # 
    error_page 404 /404.html; 
     location = /40x.html { 
    } 

    # redirect server error pages to the static page /50x.html 
    # 
error_page 500 502 503 504 /50x.html; 
     location = /50x.html { 
    } 

    # proxy the PHP scripts to Apache listening on 127.0.0.1:80 
    # 
    #location ~ \.php$ { 
    # proxy_pass http://127.0.0.1; 
    #} 
# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000 
    # 
    #location ~ \.php$ { 
    # root   html; 
    # fastcgi_pass 127.0.0.1:9000; 
    # fastcgi_index index.php; 
    # fastcgi_param SCRIPT_FILENAME /scripts$fastcgi_script_name; 
    # include  fastcgi_params; 
    #} 
# deny access to .htaccess files, if Apache's document root 
    # concurs with nginx's one 
    # 
    #location ~ /\.ht { 
    # deny all; 
    #} 
} 

回答

1

你」重新告訴nginx它必須將請求轉發到127.0.0.1:3031,但是從我從腳本看到的啓動gunicorn的內容中,gunicorn被綁定到一個套接字上,如果你將在127.0.0.1:3031上啓動你的gunicorn worker,它應該工作

+0

現在我想起來了,我不需要那部分,是嗎?你認爲它可以被刪除? 刪除該行後,我得到403禁止。 – davidb

+0

我認爲gunicorn將在端口8000上啓動,如果你刪除它 –

+0

但不是nginx應該將所有來自端口80的流量都指向該應用程序嗎? 我應該讓它0.0.0.0:80然後呢?我看到一些教程沒有這個設置。 – davidb