2017-02-16 32 views
0

最近,我開始收到一個奇怪的錯誤,當我嘗試運行我在VS程式:nativescript iOS的可可豆莢建立自己的錯誤

警告]:警告:的CocoaPods需要你的終端使用UTF-8編碼是。 [31; 1m處理node_modules失敗。例外:Pod安裝命令失敗。誤差輸出: 考慮加入以下〜/ .profile中: 出口LANG =的en_US.UTF-8

[NSDebugAdapter] TNS的命令完成了它的使用代碼127

執行有沒有人看到嗎?我看到建議的操作消息,但我不知道./profile是哪裏?

我使用TNS 2.5.0版和VS守則埃爾卡皮坦

回答

2

這個問題是通過打開bash的配置文件來解決(開〜/ .bash_profile中),並加入EXPORT LANG=en_US.UTF-8

從Telerik的感謝@NickIliev對於這個建議。有關更多詳細信息,請參閱 https://github.com/NativeScript/NativeScript/issues/3659

+0

一個解決方法:應該有'出口'而不是'出口'。 –