2012-04-28 53 views
2

我使用安裝在ruby-processing寶石:已安裝Gem。寶石的命令中沒有找到

$ sudo gem install ruby-processing 

當我嘗試運行ruby-processingrp5命令,這是輸出我得到:

rp5 run twitter_emotion_graphs.rb 
No command 'rp5' found, did you mean: 
Command 'rpm' from package 'rpm' (main) 
Command 'rpl' from package 'rpl' (universe) 
rp5: command not found 

下面是上下文更多信息(查看自述文件): https://github.com/vishrut/Twitter-Emotion-Graphs

回答

2

在某些系統(例如Debian)上,安裝gem可執行文件的路徑不在$PATH中。根據您的發行版本,該路徑位於不同的位置,在Debian上使用Ruby系統,位於/var/lib/gems/1.8/bin。要添加到系統的$PATH,把這樣的事情到一個新的文件中/etc/profile.d/rubygems.sh

export PATH="$PATH:/var/lib/gems/1.8/bin" 
+0

太好了。問題解決了。 – user1324579 2012-04-28 18:41:46

2

確保可執行文件位於路徑中。您可能必須重新啓動終端才能刷新所有內容。

+0

解決。這是問題所在。 – user1324579 2012-04-28 18:41:24

相關問題