2015-09-27 7 views
2

tl; dr;如何使用舊的(不應該使用use_frameworks!)和新的豆莢一起在podfile?
我已經工作podfile:找不到Cocoapods框架 - 混合物鏡c和快速豆莢

platform :ios, '8.0' 
use_frameworks! 

    target 'myApp' do 
     pod 'Alamofire', '1.3.1' 
     pod 'SwiftyJSON', '~> 2.2.1' 
    end 

然後我根據文檔link
所以我莢文件變更爲補充OneSignal莢:

platform :ios, '8.0' 
use_frameworks! 

target 'myApp' do 
    pod 'Alamofire', '1.3.1' 
    pod 'SwiftyJSON', '~> 2.2.1' 
    pod 'OneSignal' 
end 

我更新豆莢和運行構建 - 遇到錯誤:

ld: framework not found OneSignal 
clang: error: linker command failed with exit code 1 (use -v to see invocation) 

我查過OneSignal po d和它看起來不同: enter image description here
這可能是因爲是舊式的Objective-C框架。
我可以手動添加這個框架到我的項目,但我不知道如何使它與cocoapods正常工作? 這個問題涉及到我的問題,我認爲https://github.com/CocoaPods/CocoaPods/issues/3338


更新
我目前使用的Xcode 6.4

您正在使用什麼版本的Xcode
+0

你可以看到,這可能會幫助你:[https://medium.com/@stigi/swift-cocoapods-da09d8ba6dd2](https://medium.com/@stigi/swift-cocoapods-da09d8ba6dd2 ) –

回答

2

如果更新到Alamofire和SwiftyJSON的最新版本並使用Xcode 7構建,它應該修復您的構建錯誤。

platform :ios, '8.0' 
use_frameworks! 

target 'myApp' do 
    pod 'Alamofire', '2.0.2' 
    pod 'SwiftyJSON', '~> 2.3.0' 
    pod 'OneSignal' 
end