2016-09-19 36 views
1

因此,我安裝了AWS框架到我的應用程序中,安裝完成後沒有任何問題的谷歌地圖框架。它似乎拾起了很多錯誤。可可豆莢安裝問題

起初,我總共有兩個錯誤:「不能包含框架模塊中的非模塊化頭部...」和「無法構建Objective-C模塊'AWSS3'」。因此,我遵循了幾條線來解決這個問題,而且似乎讓它變得更糟。繼承人什麼我跟着:

  • 清潔和建立
  • 刪除DerivedData文件夾
  • 變化框架搜索路徑
  • 卸載並重新安裝的CocoaPods
  • 清理,並分別建立每一個方案。

因爲我改變了搜索路徑,錯誤的數量從2增加到9,其中大部分是「不能包含非模塊...」以及一個新的「定義」。 '必須從模塊'...'「導入。出於某種原因,我似乎也在界面'...'上看到很多警告說「類別AWS的重複定義」。總的來說,我收到了25個問題,這些問題稍微有點關注,因爲我不想做任何事情來完全搞亂我的項目。

CocoaPods將是我的死亡。

更新:在進一步更改用戶路徑中的某些內容後,我現在遇到沒有找到模塊的問題。

回答

0

爲了解決問題 「沒有發現模塊」:嘗試啓用模塊(C和Objective-C),如下圖像: enable modules

+0

已經啓用 – luke