2016-11-30 17 views
0

我想添加Alamofire和SwiftyJSON到我的項目(Xcode 8,Swift 3)使用Cocoapods 1.2.0測試版。解析問題與可可豆莢(1.2.0.beta.1)

我添加莢文件

pod 'Alamofire', '~> 4.0' 
pod 'SwiftyJSON', '3.0.0' 

然後當我吊艙安裝,我得到這個錯誤

[!] ERROR: Parsing unable to continue due to parsing error: 
contained in the file located at  /Users/<me>/.cocoapods/repos/master/CocoaPods-version.yml 
--- 
min: 1.0.0 
last: 1.2.0.beta.1 
prefix_lengths: 
- 1 
- 1 
- 1 

我搜索谷歌和發現有人用類似的問題here,並試圖安裝xcodeproj:1.4 .1,問題仍然存在。

有沒有人有任何想法這裏發生了什麼,我能做些什麼來成功安裝我的豆莢?任何幫助深表感謝。

+0

嘗試將'pod'SwiftyJSON','3.0.0''更改爲'pod'SwiftyJSON''並查看它是否有效?編輯:沒關係,我看到問題是在Cocoapods不是podfile。 –

+0

我設法通過安裝最新版本的「psych」來解決它,然後卸載psych。現在一切都按預期工作 - 我希望我能解釋爲什麼,但我很新,甚至不知道什麼是心理! – d0xi45

回答

2

我試圖通過安裝最新版本的「psych」gem來解決它,然後卸載psych。不知道問題出在哪裏,如果有更多知識淵博的人願意投入,那將是非常好的,否則對於那些將來閱讀這個問題的人 - 只需卸載psych。