2015-03-03 34 views
5

安裝更新,我想設置的CocoaPods到我的iPhone應用程序但是,當我去命令:得到錯誤設立可可豆莢和Ruby的

sudo gem update --system 

我得到錯誤:最新版本當前安裝。中止。

當我進入下一步驟的的CocoaPods:

sudo gem install cocoapods 

我得到的錯誤在Mac OS 10.8.5:

ERROR: Error installing cocoapods: 
cocoapods-trunk requires Ruby version >= 2.0.0. 

我試圖在Mac OS 10.9.4和獲得相同的錯誤:

ERROR: Could not find a valid gem 'cocoapods' (>= 0), here is why: 
     Unable to download data from https://rubygems.org/ - Errno::ECONNREFUSED: Connection refused - connect(2) (https://rubygems.org/latest_specs.4.8.gz)​ 
+0

當試圖安裝Ruby和RVM,我得到錯誤:RVM採購線沒有找到巖組,重新運行ŧ他用'--auto-dotfiles'標誌修復它的命令。並警告:*警告:您有'〜/ .profile'文件,您可能需要加載它, 可以將以下行添加到'/Users/sharmas7/.bash_profile': source〜/ .profile和錯誤的紅寶石:沒有二進制紅寶石可用:osx/10.8/x86_64/ruby​​-2.0.0-p598 – 2015-03-11 09:27:37

回答

9

我有這個同樣的問題,發現這是由於有紅寶石的舊版本安裝(即使我的OS X是10.10.2)。您需要卸載舊版本並安裝較新版本的Ruby。這些步驟對我有效:

  1. 嘗試rvm ls以查看是否安裝了更新的版本。例如,如果你這樣做,就用rvm use ruby-2.2.0

  2. 如果您沒有未使用的兼容版本,請卸載舊版本:rvm uninstall [your ruby version](如果此行出現錯誤,您可能必須先卸載cocoapods)。使用rvm current來查看您正在運行的版本。當它這樣做rvm install ruby-2.2.0

  3. rvm --create ruby-2.2.0,然後,

  4. 安裝版本2.2.0( 2.2.0爲我工作,但2.2頭沒有或使用rvm list known看到所有可用的版本) rvm use ruby-2.2.0

  5. 重新安裝的CocoaPods

+0

偉大的答案!謝謝 – SleepsOnNewspapers 2015-05-04 04:45:35

+0

我看到的升級Ruby的最佳指南。真的是 – SleepsOnNewspapers 2015-05-04 04:47:44

+0

我按照這些步驟卸載了Ruby。然後試着按照上面的方法安裝2.2,它需要一些叫做自制軟件的東西。我發現並試圖安裝它,但它需要Ruby。我殺了我的雞,現在我沒有雞蛋:) – theLastNightTrain 2015-08-26 10:58:45