2012-02-08 211 views

回答

1

需要你有一個鏈接到一個現場演示?如果沒有這一點,我只能猜測引用者(即您要放置地圖的網站)與您在API控制檯中設置的引薦對象的限制不匹配。

-

您正在使用V2 API。絕對是從加載V3 Maps API開始的。 V2 API已棄用。如果你看看你的控制檯,你只能激活該API的V3 API,而不是V2 API。

+0

livedemo位於sporkstick.com上。我只是使用API​​來獲取特定位置的座標。 – user899893 2012-02-08 19:47:41

+0

您正在使用V2 API。絕對是從加載V3 Maps API開始的。 V2 API已棄用。如果你看看你的控制檯,你只能激活該API的V3 API,而不是V2 API。 – 2012-02-08 21:06:04

+0

你是對的,他們重新命名了V3中的所有功能。這就是我的代碼沒有正確響應的原因 – user899893 2012-02-08 23:58:56

2

使用本:

src="http://maps.google.com/maps/api/js?sensor=false" 

鍵不是在V3

+0

停止給我的錯誤,但它不工作。我有一些使用V2的代碼。現在他們沒有工作。 – user899893 2012-02-08 02:11:56

+1

你有鏈接到現場代碼?聽起來你正在嘗試加載Maps API V3庫並使用V2代碼。它們不兼容。 – andresf 2012-02-08 03:28:32

+0

@ user899893在v3 api和v2 api之間存在一些差異。如果您選擇使用v3,則應查看在線文檔並進行必要更改 – trs 2012-02-08 11:52:15