2013-02-18 132 views
0

有沒有。用style-plugin知道這個問題?Rails:錯誤信息

G:\testmud>rake db:migrate:down version=20130218112415 
DEPRECATION WARNING: You have Rails 2.3-style plugins in vendor/plugins! Support 
for these plugins will be removed in Rails 4.0. Move them out and bundle them i 
n your Gemfile, or fold them in to your app as lib/myplugin/* and config/initial 
izers/myplugin.rb. See the release notes for more on this: http://weblog.rubyonr 
ails.org/2012/1/4/rails-3-2-0-rc2-has-been-released. (called from <top (required 
)> at G:/testmud/Rakefile:7) 

回答

0

你看到一個棄用警告,讓你知道,在導軌4存儲供應商的插件/插件已經贊成使用的寶石取出。如果你在目錄中有插件,你應該將它們重構成ruby寶石。如果目錄爲空,則可以安全地刪除應該刪除警告消息的供應商/插件。