2017-12-27 45 views
0

我想用papaparse來解析一個csv文件與vue,但我遇到安裝麻煩。我使用npm來安裝papaparse,並使用以下命令: npm install papaparse 但是,npm給了我這些警告: WARN [email protected] requires a peer of [email protected]^3.3.7 but none was installed.WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})。從這裏,我認爲它需要我使用bootstrap,但在papaparse上,它聲明它不需要任何依賴關係?我如何正確安裝papaparse,以便我可以在我的vue項目中使用它?試圖使用papaparse vue

+1

您是否安裝了其他軟件包?您可能會在問題頁面https://github.com/mholt/PapaParse/issues上提問更好的問題。 –

+0

您可以忽略第二個警告。 fsevents包沒有安裝,因爲只適用於MacOS(https://github.com/npm/npm/issues/12497)。 – yuriy636

回答

0

我只加了papaparse.min.js文件到我的web項目,並添加到bundleConfig,編譯和

Papa.parse 

立即工作。

只需注意保存文件的路線。